Elite oddity

reminisce about bbc micro & electron games like chuckie egg, repton, elite & exile

Related forum: adventures


User avatar
KenLowe
Posts: 199
Joined: Mon Oct 18, 2004 4:35 pm
Location: Scotland
Contact:

Elite oddity

Postby KenLowe » Tue Feb 13, 2018 7:12 pm

Not sure if this is a software or hardware query, but thought I'd post in the software section. Any idea why sometimes I get a yellow lower border and green gauges when I boot Elite and other times I get a white lower border and blue gauges? The white border changes to the yellow border as soon as it starts loading the main game.

My camera struggled to pick up the yellow colour from the monitor, which is why I've taken the photo at an angle.

This is me loading the standard version of Elite from the disc that includes the standard, SWR, Master & 2P versions.

I see the same happening with both the standard VC2023 ULA, and VideoNuLA.

I can get the white / blue screen sometimes if I boot from initial power on (but not always). I can then repeatedly get the white / blue screen on subsequent reboots as long as I don't allow Elite to boot to the main game. If I allow Elite to load the main game, I seem to get the yellow / green screen on any subsequent boot.
Attachments
Elite White.jpg
Elite Yellow.jpg

User avatar
Lardo Boffin
Posts: 807
Joined: Thu Aug 06, 2015 6:47 am
Contact:

Re: Elite oddity

Postby Lardo Boffin » Tue Feb 13, 2018 7:17 pm

The screen colours depend on whether you have docking computers fitted or something similar? Am pretty sure its down to equipment options. Edit - escape pod I think.
If you start a new game with a new commander it should be yellow / green.
Not really sure about the ‘attract’ screens. Maybe it randomly selects whether equipment is present.
BBC model B 32k issue 4, 16k sideways RAM, Watford 12 ROM board, Retroclinic Datacentre + HDD, Viglen twin 40/80 5.25" discs, acorn cassette, Acorn 6502 coproc
BBC model B 32k issue 7, turboMMC, Opus Challenger 3 512k, Pi 3 coproc
BBC Master

User avatar
KenLowe
Posts: 199
Joined: Mon Oct 18, 2004 4:35 pm
Location: Scotland
Contact:

Re: Elite oddity

Postby KenLowe » Tue Feb 13, 2018 7:28 pm

I see this on the initial loading screen, before the game starts, and before I even select to start a new game with a new commander.

User avatar
sydney
Posts: 2036
Joined: Wed May 18, 2005 9:09 am
Location: Newcastle upon Tyne
Contact:

Re: Elite oddity

Postby sydney » Tue Feb 13, 2018 7:59 pm

It seems to me that the screen is drawn before the memory location used for the presence of an escape pod has been set to 'no escape pod' so it's white/blue. Once it has been set to 'no escape pod' this remains set giving the yellow/green.


Who is online

Users browsing this forum: No registered users and 3 guests